Traps Software Requirements

Before installing Traps software, make sure that the target endpoint meets the following prerequisites:
  • ESM Server and ESM Console running the same or a later version than the Traps agent
  • Operating system: Palo Alto Networks supports Traps on many Windows operating systems. To determine the minimum Traps release for a specific operating system, refer to Where Can I Install the Traps Agent? in the Palo Alto Networks® Compatibility Matrix .
  • Virtual Environments:
    • VMware ESX
    • Citrix XenServer
    • Oracle Virtualbox
    • Microsoft Hyper-V
  • Virtual Desktop Infrastructure (VDI):
    • VMware Horizon View
    • Citrix XenDesktop
  • .NET:
    Operating System
    .NET Version
    Windows 7 and earlier releases
    .NET 3.5 SP1 or 3.5.1
    Windows 8
    .NET 4.5
    Windows 8.1
    .NET 4.5.1
    Windows 10 and later releases
    .NET 4.6
    Windows Server 2008
    .NET 3.5 SP1 or 3.5.1
    Windows Server 2012
    .NET 4.5
    Windows Server 2012 R2 and later releases
    .NET 4.5.1
    Windows Server 2016
    .NET 4.5.1
  • Allow communication on the TCP port from clients to server (the default is port 2125)
  • BITS client
  • Windows Accessories (Notepad) to view logs
  • Windows Event Log service

Related Documentation