Upgrade/Downgrade Considerations

The following table lists the new features that have upgrade or downgrade impact. Before you upgrade ESM components to or downgrade from release 4.1, make sure you understand the changes that will occur in the configuration.
Feature
Upgrade Considerations
ESM Upgrade Path
You can upgrade to ESM 4.1 from any ESM 4.0 release.
Traps Upgrade Path
If you participated in the Traps beta program, you cannot upgrade from the Traps 4.1 beta version to a Traps 4.1 release.
  • Windows XP, Windows Server 2003, Windows Server 2008, and Windows Vista—Upgrades using one-time action rules are not supported. To upgrade the Traps agent on these platforms, you must use GPO, SCCM, or another alternate method of deploying the Traps software.
  • macOS—To upgrade to Traps 4.1 using one-time action rules, you must first upgrade to Traps 4.0.4 or later releases. To upgrade the Traps agent on a Mac endpoint from a release earlier than Traps 4.0.3, you must use an external tool (like JAMF) to deploy the Traps software.
  • All other operating systems—One-time action rules are supported; however, you must upgrade to Traps 3.4.3 or later releases before you upgrade to a Traps 4.1 release.
Automated Content Updates
By default, the ESM Server now automatically downloads and distributes new content updates when they are available. To enable the ESM Server to automatically check for updates, you must enable SSL/TLS 1.2 communication between the ESM Server and the updates server (updates.paloaltonetworks.com) on port 443.

Related Documentation